日常生活

SUNのhostsはきびしい~

今日は、CentOSのマシンから、SunワークステーションのディレクトリーをNFSでマウントさせようと、後輩が頑張っておりましたが、「許可がありません」とのエラーが出て、四苦八苦しておりました。

それで、調査したところ、Sun(サーバ側)のexportsを見てみると、書式に問題なかったのですが、マウント許可するホスト名をIPアドレスに変えてみたところ、無事、つながるじゃないですか。


えっ? なぜホスト名の名前解決が出来ないの? NIS使ってる? パーミッションは? と調べてみると、hostsファイルにしっかりとホスト名は明記してあるのに、なぜかつながらない。

でも、別のマシンのホスト名はつながるものもある??

はて?/etc/hostsファイルを本当に読んでいるのかさえも疑問に思えてきた。

さらに、hostsファイルを調査してみると、あるところを境に名前解決が出来ないことが判明。


ズバリ、hosts内の書式でIPに割り当てているホスト名が空白になっていることが原因でした。


  • 192.168.1.1 hoge ○
  • 192.168.1.2 × (ここで引っかかっているので、これ以降は無効)
  • 192.168.1.3 foo △ (書式は間違っていないが、無効)
ちなみに、SunのOSはSunOS4.1.3で、この時代のhosts書式が対応していないだけのようで、現在のLinux等は間違った?書式でも問題なく動作するようです。

LinuxNetwork未分類つくば